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DOCUMENT STRUCTURE 

 

TITLE (METADATA) 

The title is the first thing that is read by a screen reader when the document is opened. It 

should be in plain language, not simply a file name. It can be added to the document metadata 

in InDesign. 

To add a document title: 

1. Click File > File Info 

2. Add the document title (in plain language) to the Document Title field 

3. Click OK. 

 

MAPPING STYLES TO TAGS 

PDF files must include tags that define the document structure. If no tags are present, a screen 

reader cannot read the document. PDF tags include heading tags (H1, H2, H3…), paragraph tags 

(P), figure tags (FIGURE, ARTIFACT), table tags (Table, TR, TH, TD, etc.). If tags are not applied 

properly or if all elements are simply tagged with a paragraph <P> tag, the document is equally 

unusable.  

InDesign paragraph and object styles should be created with semantic tags in mind and mapped 

to corresponding PDF tags and exported. 

To Map Paragraph Styles to PDF Tags: 

1. Open the Paragraph Styles panel  

2. Right-Click a style and choose:  Edit  

3. From the Paragraph Style Options dialog box, click Export Tagging 

4. In the PDF section, associate the chosen paragraph style with the appropriate semantic tag. 

If you prefer, you can choose to set all export tags at one time. In the Paragraph Styles panel, 

click Edit All Export Tags  from the menu in the upper right of the panel. Be sure to select the 

PDF radio button above the styles list. Styles translate to PDF tags 
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READING ORDER 

With a simple top-to-bottom, left-to-right text document, reading order is seldom an issue. 

With complex layouts including multi-columns, images, footers, and other special formatting, 

reading order often must be set manually. This is done by adding content to the Articles Panel. 

To set the reading order using the Articles Panel: 

1. Click Window > Articles 

2. Drag document objects to the Articles panel in the order in which they are to be read. 

3. For threaded text that spans multiple pages, it is only necessary to drag the span once. 

4. Images and other objects that are included in a threaded text frame should be anchored 

in order to maintain their proper placement. 

5. From the menu in the upper right of the Articles pane, be sure to choose Use for 

Reading Order in Tagged PDF. 

TABLE OF CONTENTS AND BOOKMARKS 

A Table of Contents is required in longer documents (8 or more pages) so that users of assistive 

technology can effectively navigate the document. They are also beneficial to sighted users. 

Bookmarks are also required for longer documents, and can be added using the Table of 

Contents dialog box. 

To generate a Table of Contents and Bookmarks: (Requires that styles already be applied.) 

1. Choose Layout > Table of Contents   

2. Click More Options to show all 

3. Name your TOC 

4. Set a TOC style 

5. Choose which styles to include in TOC 

6. Set TOC Entry Style for each style 

7. Place TOC 

8. Check Create PDF Bookmarks.  
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CROSS REFERENCES 

Cross references, or internal document links, must be properly tagged in order to allow 

effective navigation by persons using assistive technology. Creating a cross-reference involves 

selecting the link text, and then matching it with the destination (or target) in the document.  

To create cross-references: (Requires styles) 

1. Highlight the link text 

2. Click Window > Type and Tables > Cross References 

3. Click Create New Cross Reference 

4. In the New Cross Reference Dialog box, select the destination 

5. Choose cross reference format or create your own. 

TABLES 

InDesign tables can be exported to PDF with proper tagging.  You will need to make sure that 

header rows are assigned in InDesign. Take care to avoid complex or irregular table structure or 

you may need to do some clean-up manually in Adobe Acrobat. 

To set a table header row: 

1. Highlight row  

2. Choose Table > Convert Rows > To Header 

LISTS 

When creating lists, be sure to use the built-in bulleted list/numbered list option. If you want 

custom bullet styles, you can create custom bullet types by ALT (or OPT) clicking the list icon to 

open the custom bullet dialog box. 

To create a custom bullet style: 

1. ALT-Click (or OPT-click) the bulleted list icon in the button bar 

2. Choose custom bullet type and click OK 
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DOCUMENT CONTENT 

COLOR CONTRAST 

Color contrast is an often overlooked but extremely important issue for people with low-vision 

or color blindness. According to current WCAG guidelines: 

• Text sized under 18pt should have a contrast ratio of at least 4.5:1 between the text 

color and the background color  

• Text larger than 18pt should have a contrast ratio of at least 3:1. 

Use a color contrast checker such as the one available from WebAIM.org to check your color 

contrast. For more information about color contrast, see Color Contrast: Digital Accessibility 

(YouTube) on the Tufts Technology Services YouTube channel. 

IMAGES: ALTERNATIVE TEXT 

Alternative text must be added to all meaningful images in the document. Purely decorative 

images must be designated as such by being tagged as artifacts.  You can add alternative text to 

images manually or you can choose to use the descriptive text in the XMP description field in 

Bridge. 

To add alternative text to an image manually: 

1. Select the image 

2. Choose Object > Object Export Options 

3. Click Alt Text 

4. Choose Custom 

5. Add descriptive text 

To add alternative text from XMP data (e.g. Adobe Bridge): 

1. Select the image  

2. Object Menu > Object Export Options 

3. Alt text Source: XMP Description 

IMAGE CAPTIONS 

If you would like the image to have a visible caption, use the Caption Setup option. 

https://webaim.org/resources/contrastchecker/
https://youtu.be/DZiedwJVLWs
https://youtu.be/DZiedwJVLWs
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To add image captions: 

1. Object > Captions > Caption Setup 

2. Grabs information from image metadata 

3. Choose field 

4. IPTC Core: Headline field or Description field in Bridge 

5. Choose placement 

6. Choose style 

7. Object > Captions > Generate Live or Static Caption 

8. Static caption for larger captions, flows with frame 

 

INFOGRAPHICS 

Infographics can pose significant accessibility issues for blind or low-vision users. They can also 

be difficult for anyone with cognitive impairments. For this reason, it is good practice to 

summarize the content that is presented as an infographic somewhere in the textual content of 

the document. It could be a paragraph of text before or after the graphic, or it could be in the 

form of a visible (lengthy) caption.  

From an accessibility standpoint, as long as the pertinent information is also relayed in the text, 

you would be able to add alternative text to the graphic that states something like “…as 

described in the accompanying text.” 

Be sure that the infographic is a single figure (not several nested figures) so that only one object 

frame is exported to PDF. 

SHAPE OBJECTS 

Custom shape objects, especially those that contain text or communicate important 

information, must be converted to figures and given alternative text. 

To convert shape object to figures: 

1. Make sure there are no nested objects (ungroup, then regroup so that you have a single 

object) 

2. Object Menu > Object Export Options 

3. Alt Text 

4. Source: Custom 

5. Add alt text for figure 
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ARTIFACTS 

For decorative graphics. Anything left out of Articles Panel will be artifacted, but there are times 

where you may want to select certain objects and artifact them manually. 

To mark an object as an artifact: 

1. Select the object 

2. Choose Object Menu > Object Export Options 

3. Click Tagged PDF 

4. Apply Tag: Artifact 

Note: Master page items are automatically artifacted: paths, footers, page numbers, etc. 

HYPERLINKS 

Hyperlinks should be created using the built-in Hyperlinks style in InDesign. Also important to 

keep in mind is that long URLs pose a significant accessibility challenge. If the URL must be 

displayed in the document try to ensure that it is not overly long. For example, link to 

soundbeat.syr.edu rather than https://soundbeat.org/soundbeat-

widget/987ass456g3423423546345345/#tab-latest  

To create hyperlinks: 

1. Choose Window > Interactive > Hyperlinks 

2. Highlight text 

3. Click Create New Hyperlink 

4. Link to: URL, Email, Page, etc. 

5. New style created which maps to link OBJ in a tagged PDF 

FOOTNOTES AND ENDNOTES 

When done correctly, references are linked to corresponding footnote/endnote, note links back 

to the original reference in the PDF AND note is read in proper order for screen reader users. 

The accessible Footnotes/Endnotes feature is new to InDesign CC 2018. 

To use built-in footnote and endnote styles: 

1. Select the text  

2. Choose Type > Insert Footnote or Type > Insert Endnote 

3. Footnote appears at the bottom of the frame in which the reference is located. 

file:///C:/Users/pjtho/Downloads/soundbeat.syr.edu
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4. In the PDF, the footnote will result in a matched <Footnote> tag and <Reference> tag. 

5. Can manually add active hyperlink in PDF if desired. 

EXPORTING TO ACCESSIBLE PDF 

 

IMPORTANT: Don’t use the Print > Adobe PDF Printer! You will lose all of the accessibility that 

you just built into your document. 

To export to PDF in a way that retains the accessibility features, use: 

1. Choose File > Export 

2. Name your file and Save as Type: Adobe PDF (Print) or, if you are creating a fillable form, 

choose Adobe PDF (Interactive) 

3. If you choose Export Adobe PDF (Print) 

a. General 

i. Adobe PDF Preset: Smallest File Size 

ii. Pages All 

iii. Viewing: Single page, fit page 

iv. Check the box next to View PDF after Exporting 

v. Check the box next to Create Tagged PDF 

vi. Check the Optimize for Fast Web View box 

vii. Export Layers: Visible & Printable Layers 

viii. Include: Bookmarks, Hyperlinks 

ix. Interactive Elements: Do Not Include 

x. Choose Save Preset and rename so you can reuse it 

b. Advanced 

i. Display Title: Document Title 

ii. Set Language 

4. If you choose Export Adobe PDF (Interactive) 

a. General 

i. Output: Pages 

ii. Set View: Fit Page 

iii. Set Layout: Single Page 

iv. Check Create Tagged PDF 

v. Check Use Structure for Tab Order 

b. Advanced 

i. Display Title: Document Title 
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ii. Set Language 

 

VALIDATE IN ADOBE ACROBAT DC 

Once you have exported your document to Adobe PDF, you should open it in Adobe Acrobat DC 

and run the Accessibility Checker. This will allow you to make any necessary corrections. 

See Using the Adobe Acrobat DC Accessibility Checker. 

ADOBE ACROBAT DC ACCESSIBILITY ERRORS 

Error Message Troubleshooting Help 
Title - Failed See Title 

Bookmarks - Failed See Table of Contents and Bookmarks 
Tagged content - Failed See Exporting to Accessible PDF 

Tab order – Failed Right-Click and choose ‘Fix’ 

Reading order errors See Reading Order 
Figures alternate text – Failed See Images Alternative Text 

Nested alternate text – Failed See Shape Objects or Exporting to PDF/Visible 
and Printable Layers 

Table Headers – Failed See Tables 

Headings, Appropriate Nesting – Failed See Headings 
Tagged Annotations – Failed See Hyperlinks 

Other Elements Alternate Text – Failed See Alternate Text 
Table Rows – Failed See Tables 

Table Regularity – Failed See Tables 

List items – Failed See List 

 

OUTSOURCING  

Professional, fast, but expensive 

Many companies offer PDF remediation services 

Generally quick turnaround time 

Generally $8 - $10 per page 

 

https://www.adobe.com/accessibility/products/acrobat/using-acrobat-pro-accessibility-checker.html
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ADDITIONAL TRAINING AND SUPPORT 

 

ADOBE.COM 

InDesign Accessibility https://www.adobe.com/accessibility/products/indesign.html 

InDesign User Guide https://helpx.adobe.com/indesign/user-guide.html 

InDesign Tutorials https://helpx.adobe.com/indesign/tutorials.html 

https://www.adobe.com/accessibility/products/indesign.html
https://helpx.adobe.com/indesign/user-guide.html
https://helpx.adobe.com/indesign/tutorials.html
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